summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/0.17.0.0-translations-use-host-compiler.patch
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-09-26 13:56:29 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 01:18:59 +0100
commit36ba7f47d6fee9f5eb992eadeaf59907f0100ced (patch)
treea5fd8e4d2e2bfaf0cc28e4b842ab50918e993a77 /net-p2p/monero/files/0.17.0.0-translations-use-host-compiler.patch
parentprofiles/server: bump net-p2p/xmr-stak-rx (diff)
downloadportage-36ba7f47d6fee9f5eb992eadeaf59907f0100ced.tar.xz
net-p2p/monero: version bump
Package-Manager: Portage-3.0.4, Repoman-3.0.1
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/files/0.17.0.0-translations-use-host-compiler.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.17.0.0-translations-use-host-compiler.patch b/net-p2p/monero/files/0.17.0.0-translations-use-host-compiler.patch
new file mode 100644
index 00000000..b3ae7d7d
--- /dev/null
+++ b/net-p2p/monero/files/0.17.0.0-translations-use-host-compiler.patch
@@ -0,0 +1,30 @@
+From 076e09cffce6c184ea75d4a3e7db61102215e52e Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 2a16e00817e6..0eb2a5089248 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -468,7 +468,12 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_C_COMPILER=$ENV{BUILD_CC}
++ -DCMAKE_CXX_COMPILER=$ENV{BUILD_CXX}
++ -DCMAKE_C_FLAGS=$ENV{BUILD_CFLAGS}
++ -DCMAKE_CXX_FLAGS=$ENV{BUILD_CXXFLAGS}
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)