summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/0.16.0.0-translations-use-host-compiler.patch
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2020-05-21 22:09:27 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2020-10-18 00:21:10 +0100
commit516ed4e153c2e515dd68b81af5cdfbe5a425e463 (patch)
treef7446365386f9adc0fc1d832e953b6ee41f56ddc /net-p2p/monero/files/0.16.0.0-translations-use-host-compiler.patch
parentprofiles/desktop: enablle cryptsetup USE flag for sys-apps/util-linux (diff)
downloadportage-516ed4e153c2e515dd68b81af5cdfbe5a425e463.tar.xz
net-p2p/monero: version bump
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/files/0.16.0.0-translations-use-host-compiler.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.16.0.0-translations-use-host-compiler.patch b/net-p2p/monero/files/0.16.0.0-translations-use-host-compiler.patch
new file mode 100644
index 00000000..1dd1af02
--- /dev/null
+++ b/net-p2p/monero/files/0.16.0.0-translations-use-host-compiler.patch
@@ -0,0 +1,30 @@
+From f5670abe068eb90650533ff64a354568ab47b84a Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sat, 30 Nov 2019 02:09:14 +0000
+Subject: [PATCH] translations: use host compiler
+
+Do not pass target compiler and compiler flags as
+generate_translations_header need to be created using host compiler and
+compiler flags
+---
+ CMakeLists.txt | 7 ++++++-
+ 1 file changed, 6 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index d9ec866e49ec..882bc96c56a2 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -453,7 +453,12 @@ ExternalProject_Add(generate_translations_header
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/translations"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/translations"
+ STAMP_DIR ${LRELEASE_PATH}
+- CMAKE_ARGS -DLRELEASE_PATH=${LRELEASE_PATH}
++ CMAKE_ARGS
++ -DCMAKE_C_COMPILER=$ENV{BUILD_CC}
++ -DCMAKE_CXX_COMPILER=$ENV{BUILD_CXX}
++ -DCMAKE_C_FLAGS=$ENV{BUILD_CFLAGS}
++ -DCMAKE_CXX_FLAGS=$ENV{BUILD_CXXFLAGS}
++ -DLRELEASE_PATH=${LRELEASE_PATH}
+ INSTALL_COMMAND cmake -E echo "")
+ include_directories("${CMAKE_CURRENT_BINARY_DIR}/translations")
+ add_subdirectory(external)