summaryrefslogtreecommitdiff
path: root/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch
diff options
context:
space:
mode:
authorBertrand Jacquin <bertrand@jacquin.bzh>2018-07-31 18:19:53 +0100
committerBertrand Jacquin <bertrand@jacquin.bzh>2018-08-02 23:51:37 +0100
commitc65520ee8d131a753c87619c9fd67fa06cdf1a2d (patch)
tree8772fbd392ea675844bbf5bfc34b9dc77db29cf8 /net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch
parentprofiles/server: Remove python blocker on net-irc/irker (diff)
downloadportage-c65520ee8d131a753c87619c9fd67fa06cdf1a2d.tar.xz
net-p2p/monero: Version bump
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to '')
-rw-r--r--net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch b/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch
new file mode 100644
index 00000000..c7b9d543
--- /dev/null
+++ b/net-p2p/monero/files/0.12.3.0-Drop-in-tree-miniupnpc.patch
@@ -0,0 +1,57 @@
+From 694352e707574580d4249ead6673ffa2e7fcd0c2 Mon Sep 17 00:00:00 2001
+From: Bertrand Jacquin <bertrand@jacquin.bzh>
+Date: Sun, 17 Jun 2018 22:34:11 +0100
+Subject: [PATCH] Drop in-tree miniupnpc
+
+Since 6b8539803184 ("Build: update CMake and p2p for in-tree
+miniupnp"), a hard dependency is made on miniupnpc which is a git
+submodule not part of the archive available upstream.
+---
+ external/CMakeLists.txt | 16 +++-------------
+ src/p2p/net_node.inl | 6 +++---
+ 2 files changed, 6 insertions(+), 16 deletions(-)
+
+diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
+index 1fc4d64c1cbf..48a6a9a32f08 100644
+--- a/external/CMakeLists.txt
++++ b/external/CMakeLists.txt
+@@ -36,19 +36,9 @@
+ # others.
+
+ find_package(Miniupnpc REQUIRED)
+-
+-message(STATUS "Using in-tree miniupnpc")
+-
+-add_subdirectory(miniupnp/miniupnpc)
+-
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+-endif()
+-
+-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
++set(UPNP_STATIC false PARENT_SCOPE)
++set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
++set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
+
+ find_package(Unbound)
+
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index 07f369d40544..e10e4cfbc606 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -49,9 +49,9 @@
+ #include "storages/levin_abstract_invoke2.h"
+ #include "cryptonote_core/cryptonote_core.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++#include <miniupnpc/miniupnpc.h>
++#include <miniupnpc/upnpcommands.h>
++#include <miniupnpc/upnperrors.h>
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"