aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorbeber <beber>2005-12-08 23:31:42 +0000
committerbeber <beber>2005-12-08 23:31:42 +0000
commit9b9adbda1ad4ee736ebb2c05910843ada01930e6 (patch)
tree191f92682208a507e76a2e7c3f77f5c25cf386b2 /configure.in
parentadd a m4 macro for glibc (diff)
downloadespik-9b9adbda1ad4ee736ebb2c05910843ada01930e6.tar.xz
make _ESPIK_DEBUG_ defined at configure step
avoid multiple definition
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 44086ca..1e9ec7f 100644
--- a/configure.in
+++ b/configure.in
@@ -20,6 +20,31 @@ AC_C___ATTRIBUTE__
AC___GNUC__
AC___GLIBC__
+dnl Debug mode
+AC_ARG_ENABLE(
+ [debug],
+ AC_HELP_STRING(
+ [--enable-debug],
+ [Enable debug mode (default=no)]),
+ [if test "$enable_debug" = "no" ; then
+ enable_debug="no"
+ else
+ if test "$enable_debug" = "yes" ; then
+ enable_debug="yes"
+ fi
+ fi],
+ [enable_debug="no"])
+
+dnl Check debug mode
+if test "$enable_debug" = "yes" ; then
+ DEBUG_MODE_CFLAGS="-g -D_ESPIK_DEBUG_"
+ our_cxxflags_defaults="-Wall -W"
+else
+ SPECIFIC_LDFLAGS="-s ${SPECIFIC_LDFLAGS}"
+fi
+
+AC_SUBST(DEBUG_MODE_CFLAGS)
+
AC_ARG_WITH(ecore-config,
[ --with-ecore-config=ECORE_CONFIG use ecore-config specified ],
[